Development resources at your finger tips
Build with the coolest Web3 projects
Recurring funding for Open Source
Ethical ads to power Open Source
Learn about Web3 & earn rewards
Show appreciation for each other
Meet fellow developers, designers, futurists and more. Collaborate and BUIDL awesome projects together.
Follow the orgs you like more with tribes and build relationships and meaningful projects.
Meet the top hunters and contributors from our community.
Most people working with Ethereum have questions about ETH2.0. Kevin Owocki hosted some developers working on the project for a recent episode of the…
Sia recently ran the Skynet Hackathon with Gitcoin for Skynet’s launch, leading to over 40 project submissions in a 2 week period. This piece, …
Gitcoin is GDPR complaint. Learn more in
Gitcoin's Terms & Conditions.
Check out the Issue Explorer
Looking to fund some work? You can submit a new Funded Issue here.
Code like `IntegerType(160, IntegerType::Modifier::Address);` is very common and should be replaced by something like `ElementaryTypes::Address` (i.e. ElementaryTypes should be a struct that contains several static members initialized to specific instances of the types) at least for the more common elementary types to improve readability.
Note that the Type class inherits from `std::enabled_shared_from_this` and thus is always a `shared_ptr`. The elements of the `ElementaryTypes` struct should be the types themselves, but this has to be checked during implementation what is more common.
The elementary types should be:
`bytes32`, `byte`, `address`, `uint256` and others that are found in the code.